
Host-To-Mac Data Transfer Overview

Enter Host Command to Start Download
Any command that your host understands to start the data transfer.

Click OK and MacWise will begin the download. 
If you decide that you did something wrong and you would like to stop the download prematurely, you 
may abort the download by pressing the Command and Period keys at the same time.
While downloading is in progress, the cursor will change into a watch. Wait until the cursor returns to 
normal and the message, Download Complete appears before doing anything else.

NOTE: This is a text data transfer.

Auto NoPage
Sends a (N after the host command which tells a PICK host to display in NoPage continuous mode.

Time-Out-Period
Wait this long after data stops coming from the host to end the transfer.

Convert to SpreadSheet/Database Format
This will convert carriage returns to tabs. If you select Yes, then “Number of Fields Per Record” and 
“Lines to Skip Before First Record” will be used to do the conversion.

Number of Fields Per Record
Example: 5 fields per record (Company, Street, City, Phone, Contact

Lines to Skip Before First Record
This is the number of lines of unusable data before the first label. This is normally one. If you get this 
number wrong, your data will appear shifted by one or two columns in a spreadsheet. If this is the case, 
you can find out exactly how many lines to skip by running your Proc from TCL and stopping the 
display just after the data starts to show up on the screen. (To stop the display, use Command 1. 
Command 2 restarts the display. The Command key is the same as the Apple key.) Now, with the data 
stopped and on the screen, count the number of lines between the Proc name you typed and the first 
line of the label and use it as the Number of Lines to Skip.

Transferring Data To and From PICK Host Computers
These instructions also apply to Universe and Unidata host computers.

Host-to-Mac Data Transfer

Data can be transferred from a PICK host computer to your Macintosh in two ways. The data can be 
converted to a format usable by spreadsheets and databases or it can be transferred directly with no 
conversion.

Convert to Spreadsheet / Database Format

This option converts data from the PICK host to spreadsheet or database format (See Figure 1-4). Data 
sent to the Mac in a labels format can be directly loaded into a Macintosh database. (See Table 1-1 for a 
Proc that will transfer the data in a labels format.  See Table 1-2 for a Proc that uses Multivalued fields). 
This same data can be loaded into a Macintosh spreadsheet. Each label (or record) will become a new 
row in a spreadsheet.



EXAMPLE:
The following data is sent from the host to the Mac in a labels format. (Only two labels are shown for 
simplicity:)

JOHN’S ROADHOUSE
1211 EAST PINE
SEATTLE, WA 99999
(206) 223-5555
JIM GATLIN

MURRAYS PRINTSHOP
4782 NORTH PIKE
SEATTLE, WA 77777
(206) 221-5555
JILL SCOTTS

After conversion the labels can be loaded into a Mac database and will be in the same labels format. Of 
course your database can now turn the labels into a tables format if you desire.

The same labels sent from the host can be loaded into your Mac spreadsheet. Each label becomes a row: 

JOHN’S ROADHOUSE   1211 EAST PINE   SEATTLE, WA  99999
MURRAYS PRINTSHOP  4782 NORTH PIKE  SEATTLE, WA  77777 



A Proc for Transferring Data
Table 1-1

This is the number of lines of unusable data before the first label. This is normally one. If you get this 
number wrong, your data will appear shifted by one or two columns in a spreadsheet. If this is the case 
you can find out exactly how many lines to skip by running your Proc from TCL and stopping the 
display just after the data starts to show up on the screen. (To stop the display, use Command 1. 
Command 2 restarts the display. The Command key is the same as the Apple key.) Now, with the data 
stopped and on the screen, count the number of lines between the Proc name you typed and the first 
line of the label and use it as the Number of Lines to Skip.

Figure 1-4
Transferring Data with Multivalued Fields

Here is a simple way to transfer Multivalued fields to the Mac using exploding lists or 
sorts. All you have to do is add BY-EXP to the download Proc. Here is an example of a 
Proc you would use if you had multiple CONTACTS at each company:

001 PQ
002 HSORT-LABEL ONLY CUSTOMERS COMPANY STREET
    CITY PHONE CONTACT BY-EXP CONTACT ID-SUPP
    COL-HDR-SUPP
003 STON
004 H1,5,1,0,20,0

_______________________________________________



NOTES:  CONTACT is a Multivalued field.
BY-EXP CONTACT lists all multiple occurrences of  CONTACT.

Refer to the original data transfer Proc (A Proc for transferring data). 

Table 1-2

STEP BY STEP  Data Transfer with Conversion

1.   Write a Proc on the host computer for transferring data to the Mac in a labels format. (See Table 
1-1).

2.   Choose Host-to-Mac Transfer from the File menu. A window will appear with options for 
transferring data. (See Figure 1-4).

NOTE
If you don’t have flow control enabled and your baud rate is set higher than 1200, you will see the 
following message.

At this point you would click on OK and select Enable Xon/Xoff from the settings menu (make sure 
there is a check mark by it) or lower the baud rate to 1200. If you leave the baud rate higher than 1200 
and enable Xon/Xoff, make sure it is also enabled at the host end.

3.    The cursor will be flashing in the first input window ready for you to type your PICK command. 
Type the name of the Proc you created in step 1.

4.    Hit the tab key twice to move the cursor down to the Number of Fields Per Record input window. 
Enter the number of fields (or items) you specified in step 1. 

NOTE

You must enter the number of fields per record. Data will not be transferred correctly unless this is done.

5.    Using the mouse, click on Auto Nopage OFF. There is no need to specify Nopage since your Proc 
is already doing it.

NOTE

The time-out period defaults to 5 seconds. There is normally no need to change it. This is the time 
period MacWise™ uses to see if the transfer is done. If no data is transmitted for 5 seconds, the 
download terminates and is assumed to be done. If you find that your data transfer is stopping before all 
of the data has been transferred, then increase the time-out period. You can select 5 sec, 10 sec or enter 



your own time.

6.   Select the Number of Lines to Skip. This is the number of lines of unusable data before the first 
label. This is normally one. If you get this number wrong, your data will appear shifted by one or two 
columns in a spreadsheet. If this is the case, you can find out exactly how many lines to skip by running 
your Proc from TCL and stopping the display just after the data starts to show up on the screen. (To 
stop the display, use Command 1. Command 2 restarts the display. The Command key is the same as 
the Apple key.) Now, with the data stopped and on the screen, count the number of lines between the 
Proc name you typed and the first line of the label and use it as the Number of Lines to Skip.

7. When you are satisfied that everything in the transfer window looks correct, click on OK.

8.   A window will now appear to let you specify the name of the file you want  the data saved to on 
your Mac disk. Enter any name you desire and press return.

9.   MacWise™ will now begin the download. You should see the following message:

SENDING COMMAND ‘Your Proc Name’
Download in progress
COMMAND Period to abort

If you decide that you did something wrong and you would like to stop the download prematurely, you 
may abort the download by pressing the Command and Period keys at the same time.

10.   While downloading is in progress, the cursor will change into a watch. Wait until the cursor 
returns to normal and the message, Download Complete appears before doing anything else. 

11.   You may now exit MacWise™ (Quit under the File menu) and run your database or spreadsheet 
program to load in the newly created file. These programs may ask you what type of file you are 
loading. The file type will be TEXT or TEXT W/TABS.

NOTE
You can also load your converted file into a word Processor. If you have Microsoft Word, load the 
converted file into Word, then use the style sheet on the MacWise™ disk called Spreadsheet Style. 
This style sheet is set up with wide tab stops so your file will appear in spreadsheet format in Microsoft 
Word. See page 48 for instructions on the use of style sheets. If you use a different word processor, just 
make sure the tab stops are set to at least 2.5- inch increments or else the results will look very 
confusing on the screen. 



Figure 1-5

Using a BASIC Program to Transfer Data to the Mac

Page 1 explains the use of Procs to transfer data from the host computer to the 
Macintosh. This only needs to be done if you want to transfer data for use in 
spreadsheets or databases on the Mac. If your host system does not support Procs, you 
can use a BASIC program instead. This example program does the same thing as the 
Proc in the manual. 

0001: DATA "1,5,1,0,20,0"
0002: EXECUTE "LIST-LABEL ONLY CUSTOMERS COMPANY STREET CITY 
PHONE CONTACT ID-SUPP COL-HDR-SUPP"
0003: END

If you are transferring data with Multivalued fields, add the statement BY-EXP to the 
field that has multivalues as shown below:

0001: DATA "1,5,1,0,20,0"
0002: EXECUTE "LIST-LABEL ONLY CUSTOMERS COMPANY STREET CITY 
PHONE CONTACT BY-EXP CONTACT  ID-SUPP COL-HDR-SUPP"
0003: END

Transfer Data with No Conversion

This option transfers data from the host to your Mac without doing any conversion. Data transferred in 
this method can be loaded into a Mac word processor. Use this option if you don't need to transfer data 
into a spreadsheet or database.



Any standard PICK command that lists information to the screen can be used, such as LIST or 
RUNNOFF. The following describes the data transfer process step by step.

STEP BY STEP  Data Transfer with No Conversion

1.    Choose Host-to-Mac Transfer from the File menu. A window will appear with options for 
transferring data. (See Figure 1-5.)

NOTE
If you don’t have flow control enabled and your baud rate is set higher than 1200, you will see the 
following message.

At this point you would click on OK and select Enable Xon/Xoff from the settings menu (make sure 
there is a check mark by it) or lower the baud rate to 1200. If you leave the baud rate higher than 1200 
and enable Xon/Xoff, make sure it is also enabled at the host end.

2.   The cursor will be flashing in the first input window ready for you to type your PICK command. 
Type a PICK command to transfer data to the Mac. The example in Figure 1-5 shows LIST MD as the 
command.

3.   Do not change the Convert to Spreadsheet/Database Format option. It defaults to NO.

4.   MacWise™ defaults to Auto Nopage ON. This causes a (N to be sent after the command. In this 
example the command transmitted will be LIST-MD (N.  Auto Nopage is necessary because normally 
when you list the master dictionary to the screen, your host will stop after each screen of data and wait 
for you to press carriage return to see the next screen. If this were the case, MacWise™ would time-out 
during a transfer as soon as the first page was sent to the screen.

NOTE
The time-out period defaults to 5 seconds. There is normally no need to change it. This is the time 
period MacWise™ uses to see if the transfer is done. If no data is transmitted for 5 seconds, the 
download terminates and is assumed to be done. If you find that your data transfer is stopping before all 
of the data has been transferred, then increase the time-out period. You can select 5 sec, 10 sec or enter 
your own time.

5.  When you are satisfied that everything in the transfer window looks correct, click on OK.

6.   A window will now appear to let you specify the name of the file you want  the data saved to on 
your Mac disk. Enter any name you desire and press return.

7.   MacWise™ will now begin the download. You should see the following message:

SENDING COMMAND ‘Your Command’  
Download in progress



COMMAND Period to abort

If you decide that you did something wrong and you would like to stop the download prematurely, you 
may abort the download by pressing the Command and Period keys at the same time.

8.   While downloading is in progress, the cursor will change into a watch. Wait until the cursor returns 
to normal and the message, Download Complete appears before doing anything else. 

9.   You may now exit MacWise™ (Quit under the File menu) and run your word processor program to 
load in the newly created file. The word Processor may ask you what type of file you are loading in. The 
file type is TEXT.

Mac-To-Host Data Transfer

You can send a text file from your Macintosh disk to your host computer. Select Mac-To-Host 
Transfer under the File menu. 

NOTE
If you don't have type-ahead on your host, you can experiment with different delay times. Select Mac-
To-Host Delay from the Edit Menu and enter a delay time. This will give the host enough time to 
accept each line of data before the next one is sent. (You only have to set the delay time once. 
MacWise™ will always remember the delay time you selected). Try the data transfer first before 
changing the delay time. Chances are very good that you won't have to change the delay time.

Just select a file to transfer and the data will be sent.
NOTE: Your PICK host must be in a mode ready to receive the data (in the insert mode of the editor or 
word processor; or the Mac-To-Host program supplied with your MacWise™ disk is running.)

When using the PICK editor to receive your data, make sure your text file does not contain any blank 
lines. The editor will exit the insert mode as soon as it sees a blank line.

When using a PICK word processor to receive the data, make sure that the hyphenation mode is turned 
off. If you leave hyphenation turned on, the word processor will stop and ask you to hyphenate a word 
during the data transfer and all of the data will not be transferred.

Mac-To-Host Program

Your MacWise™ disk has a file called MAC.TO.HOST PROGRAM. This is a PICK BASIC program 
which you can transfer to your host computer. When compiled and run, it receives data from a 
Macintosh text file and puts it in a file called HOLD on your host computer. Each line received by the 
host from the Mac becomes a new item in the HOLD file.

You don't need to type this program on your host computer. Just send it from your Mac to your host 
with the Mac-To-Host Transfer option in MacWise™.
Sending the Mac-To-Host program

to Your Host computer.

1. At TCL enter: ED BP MAC.RECEIVE to create a new program.
2. Enter I for insert mode.



3. Select Mac-To-Host Transfer from the File Menu.
4. Select MAC.TO.HOST PROGRAM  from the list of files.         
     The program will be sent to your host computer. You will notice a counter at the 
bottom of the screen which counts the lines transmitted to the host. When the counter 
stops, you will know the transfer is done.
5. Enter FI to file it.
6. Type BASIC BP MAC.RECEIVE to compile it.
7. Type RUN BP MAC.RECEIVE to run the program.

NOTE:  MAC.RECEIVE is an arbitrary name. You can use any name you choose.


